Central Forums Helpbot
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
Pages: 1 2 3 [4] 5 6 7 ... 10
 31 
 on: May 19, 2013, 12:57:48 AM 
Started by zon - Last post by Llie
I think this feature is essentially added to my raffle plugin as "raidroll".

https://bitbucket.org/Llie/vhabot_plugins_llie/raw/tip/ll_Raffle.cs

 32 
 on: May 14, 2013, 05:20:21 AM 
Started by Sunstrings - Last post by Sunstrings
umm hi i was browsing through:

https://bitbucket.org/Llie/vhabot_plugins_llie/src (umm is there still an older index like sitemap for viewing the sources umm or svn\trunk\whatevers...)

and i notice the simple !store manager so curious if this is used instead of <?php?>bots style !bank ...well nice one anyways and it is not seen in the VhaBot 0.7.10 CE (umm funny but why is this still a beta) yup i like ...

 33 
 on: May 13, 2013, 11:58:18 AM 
Started by Sunstrings - Last post by Sunstrings
http://budabot2.googlecode.com/svn/trunk/modules/BANK_MODULE/

umm, im not that very good in php, but anyways can someone port this to vhabot's plugins, i would really like too c it on my orgbot, i see there is sql combined with php, i was wondering if perhaps xml can be used alternative to sql...
also i was viewing - im unsure if its same in bebot plugins/modules there were actually separated C# style "classes(like from java)" so there were (um in some older versionz bot) split multi parts of files that forms alltoghether one module in the end i have not noticed a plugin like that on vhab bot which handles just parts of plugin and are more transparent(less cluttered code)... now i got surprised when i notice only 1 file for a plugin and it is nice.. well from whats been posted on developing nextgen bot and that nextgen plugin wont work in older versionsif i may say have in mind that bot users have an option to copy custom plugins from older versions or from nextgen to ..so that the plugin works in "merged server"...VhaBot 0.7.10 CE and before merge was i d like compare all changes made right now its unknown to me what bot version i had/have on my computer or it is only obvious change made regarding server name and ids?

 34 
 on: April 26, 2013, 02:38:03 PM 
Started by Llie - Last post by Llie
necro post, but I finally learned about this a couple of months ago so I figure I should share:

The mutibyte encoded file(s) are indeed UTF-16 and converting them to UTF-8 is the right thing to do.  I've since changed the text encoding of all the files in my project to UTF-8.

The multibyte "garbage" that I saw at the beginning of some of the files is a "Byte Order Mark" (BOM) (see: http://en.wikipedia.org/wiki/Byte_order_mark.  It is unneeded for UTF-8 (single bytes don't need byte ordering information) and was probably left over from some UTF-16 encoding conversion to UTF-8.  Can be safely removed if the file is correctly encoded as UTF-8.

I recommend for maximum compatibility of VhaBot (.NET on Windows and Mono everywhere else) all files should be encoded UTF-8. I've done some tests, and it's the only encoding where the >> character on VhaBot replies is ever encoded correctly everywhere you run the bot.

 35 
 on: April 09, 2013, 09:46:20 PM 
Started by Neksus - Last post by veremit
Is Neksus still around .. would be interested to know if s/he still has the source code for the VhabotGUI and would be willing to release it if so.

 36 
 on: March 14, 2013, 04:42:23 AM 
Started by Llie - Last post by Llie
My plug-ins can be downloaded from my BitBucket repository now:

https://bitbucket.org/Llie/vhabot_plugins_llie/src/tip/ll_Raffle.cs?at=default

 37 
 on: March 14, 2013, 04:41:23 AM 
Started by ChaosSystem - Last post by Llie
Just to cross link why this feature request is marked as done: http://vhabot.unarmed-forces.co.uk/index.php/topic,6771.0.html

 38 
 on: March 07, 2013, 08:20:14 AM 
Started by Llie - Last post by Llie
Just wanted to clarify what's what with VhaBot.



https://bitbucket.org/Vhab/vhabot

Vhab released a fix for the main VhaBot and bumped the version number to 0.7.10. 

Aside from supporting the new server, there are not other enhancements to this version of the bot.



http://www.vhabot.com

Kilmanagh actually has two versions of the bot that he is actively developing.  One version he is calling "VhaBot Classic", which he has bumped to version 0.8.1.  This version supports the new server.

Besides supporting the new server he has made tons of changes to the bot itself and incorporated several of my plug-ins.  This version of the bot deals with many of the "dead third-party services".  On top of that he has many more plug-ins.  This bot includes plugins for LE procs, DOJA chips, and more.

Kilmanagh also has a yet-unreleased "Next Generation" version of VhaBot.  That one will also support the new server with tons of new features.  I don't know too much more about this version.  But people should be aware of it and understand that it's fundamentally different from all the other VhaBots when it gets released.  It might be mostly backwards compatible with most of the current VhaBot plug-ins, but "Next Generation" VhaBot plug-ins won't work on the other branches of VhaBot.



https://bitbucket.org/Llie/llie_vhabot/

Then there's my branch off the VhaBot tree, "Llie's Edition".  My 0.7.11_LE release supports the new server.  I've remoced any references to server names, server IDs, ports or addresses from my version of the Bot and AoLib.  My version of the bot reads it all from an XML file.  As such any of my plug-ins that depends on the Server enumeration no longer work in other versions of VhaBot (most notably the XML Services plug-in, which answers the !whois and !org commands).

I've made a few small bug fixes to my core, and I've tried to pull as many fixes as I could from Kilmanagh "VhaBot Classic" branch as I could.  The bulk of the changes in my branch have been made to the plug-ins.  Some have been incorporated into Kilmanagh's "VhaBot Classic", but there are a few other plug-ins too.

 39 
 on: March 03, 2013, 05:34:54 PM 
Started by Llie - Last post by Llie
I've taken down my patchy hacky AoLib.dll that tries to make things work going backwards.  The decision by FC to make the new server ID 5 makes too many things broken.

People should download Vhab's 0.7.10 https://bitbucket.org/Vhab/vhabot release or my 0.7.11_LE https://bitbucket.org/Llie/llie_vhabot/overview release for post-merge server compatibility.

If people decide to go with my fork, the good thing is that I've completely removed references to all hard-coded server names, so at least things will be easier if something like this ever happens again.

 40 
 on: February 27, 2013, 12:17:53 AM 
Started by Llie - Last post by Llie
I've recompiled AoLib with the new chat servers.  Now Atlantean and Rimor both map to the new Rubi-Ka dimension. 

If you don't want to upgrade to the new 0.8.x release or my 0.7.11 release of VhaBot, try dropping this AoLib.dll into your bot directory and maybe everything will work.

https://bitbucket.org/Llie/llie_vhabot/downloads/AoLib_for_0.7.9.zip

Alternatively, I think the new version of my fork of VhaBot 0.7.11 will work on the new chat servers.

Pages: 1 2 3 [4] 5 6 7 ... 10